Pocketbike Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
1,269 Posts
Dai D168 said:
I thought is was a FF? I could be wrong, but didn't he cut the silencer out and welded another silencer?
He has a hf, but he installed a blata 2.5 full fairing on it....he said he took off his motor, back tire, and body off....lmao, thats a lot....Im getting my Ip2 pipe soon, I will try by taking the motor mounts off and wigglying the pipe in and pushing the motor as far back.....I hope I can get a great performance change...
 

·
Registered
Joined
·
943 Posts
I made the carbon chainguard myself out of flat stock
As far as installing the pipe, you should be able to slip it thru the back end of the bike but you really have to unbolt the engine to get the pipe attached to the exhaust port. The reason why is that the pipe has such a bend by the drive side exhaust bolt that you have to thread the bolt into the exhaust outlet on the head then slide the pipe into the bolt from the side. The mounting hole on that side is a slot, and I would recommend getting a hex head bolt and using a open ended wrench to tighten it down. You might have to see the pipe to understand all the above. I'll take some pics tomorrow if you want, to try and help explain it.
 

·
Registered
Joined
·
943 Posts
true, I'm still fine tuning the Walbro. And yes you'll probably have to unbolt the engine unless your frame was more roomy than mine. I have a FF frame coming Monday that I'm building up eventually, hopefully that will be alittle easier to fit it into.
 

·
Registered
Joined
·
943 Posts
yeah it fired right up, it had a serious bog at WOT though, and was running real rich at idle. Huge difference from stock pipe, seemed to run richer for some reason, I'm getting it worked out slowly, thinking about getting a Dellorto after messing around with the walbro so much, it's really finicky about hi and low settings. I'd rather be riding than adjusting the carb.
 

·
.
Joined
·
92 Posts
walbro

what walbro model are you using,wt or wyk.



tblumer said:
yeah it fired right up, it had a serious bog at WOT though, and was running real rich at idle. Huge difference from stock pipe, seemed to run richer for some reason, I'm getting it worked out slowly, thinking about getting a Dellorto after messing around with the walbro so much, it's really finicky about hi and low settings. I'd rather be riding than adjusting the carb.
 

·
Registered
Joined
·
1,269 Posts
Oh, so it DID start right away....sweet....then you just needed to get it leaner??

So you think if I add the adjustable jet and lean it out, it will run good??

Or is it different on your carb from the stock cag carb since yours is walbro...??

THANKS
 
1 - 20 of 25 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top