Pocketbike Forum banner
1 - 20 of 82 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
Ok so today I took out the bike and I rode around for about 7-10 minutes.So im pulling into the driveway and it shuts off on me.I push it to the garage and try cranking it again.here is what happens.The first time its starts then after 2seconds of idle it dies.the second time it cranks and dies.after that it wont crank at all.I let it sit for about 10min and I crank it and nothing.After trying for a while I get the starter spray and it starts.so I hop on and give it throttle and it bogs down and dies.I noticed if I give it gas very slowly it will stay on and youll be able to ride.Does anyone know what it can be? Im at a total lost
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #7 ·
Ok so I richen the fuel mix twice at 1/4 turn intervals.when it cranks it idles.the second I give it throttle it bogs down and dies.Im right now taking apart the carb and giving it a good cleaning.maybe a piece of trash is blocking fuel flow?? I noticed the the primer bulb is completely full, never seen that happen.
 

·
Banned
Joined
·
21,742 Posts
Ok so I richen the fuel mix twice at 1/4 turn intervals.when it cranks it idles.the second I give it throttle it bogs down and dies.Im right now taking apart the carb and giving it a good cleaning.maybe a piece of trash is blocking fuel flow?? I noticed the the primer bulb is completely full, never seen that happen.
The primer bulb is supposed to be completely full...Thats a good thing

It looks like according to the plug burn that youre running lean on both ends.........turn out the L needle 1/4 turn and turn out the H needle 1/2 turn to richen them........turn the idle screw inwards 3/4's of a full turn to pre-compensate

The factory needle settings to start with are L : 1 1/4 ////// H : 1 1/4

Start the bike using the choke.....Turn off choke after 15-20 seconds and let the bike warm up for a minute... If bike doesnt start without aid of the throttle or stalls soon after starting turn the idle screw inwards another 1/2 turn then restart........adjust idle higher if needed

If it restarts good and idles good give it test ride.......Hopefully it rides great...If not richen the highspeed needle starting in 1/8 turn incriments til you get desired topend speeds....Adjust the L needle for getting good bottomend takeoff power if needed........Good Luck
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #9 ·
Ok so I got an update.Cam I took apart the carb and look at what I found

Here it is apart to start cleaning


Bottom of car on the top is a circle with a mesh and it was full with dirt, paint chips from inside the gas tank.


Gave the manifold a once over


Freshly assembled carb looking nice and clean
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #11 ·
Ok so if you look at the pic of the carb that line that comes out from the primer bulb doesnt go anywhere so if i pump it ,it will just pour onto the floor,*** to that....There is no nozzle to connect it to.Thats 1 issue.

Second Issue is that the choke lever does not move.I have to loosen the carb itself to be able to move the choke stick.So I loosened it and left the chole open and tighten it back up.Its not suppose to do that,Does anyone know why its doing that?

Issue number 3 that after I put everything back together and cranked the bike.After having the bike running for it bit I turn the key off but the bike instead ofthe bike shutting of it kept running.Do you know why this could be??I havent touched any cables or anything electric for that matter.
 

·
Banned
Joined
·
21,742 Posts
Ok so if you look at the pic of the carb that line that comes out from the primer bulb doesnt go anywhere so if i pump it ,it will just pour onto the floor,*** to that....There is no nozzle to connect it to.Thats 1 issue.

Second Issue is that the choke lever does not move.I have to loosen the carb itself to be able to move the choke stick.So I loosened it and left the chole open and tighten it back up.Its not suppose to do that,Does anyone know why its doing that?

Issue number 3 that after I put everything back together and cranked the bike.After having the bike running for it bit I turn the key off but the bike instead ofthe bike shutting of it kept running.Do you know why this could be??I havent touched any cables or anything electric for that matter.

#1 issue solution...either tee that line back into the feed line of run it back to the tank with the 3mm tygon fueline and poke a hole into the gastank with a #1 tip screwdriver and feed the line into the tank and use a lil RTV to seal it..............

#2 the choke lever should be kinda loose...I remove the black-oring from the v-stack thats used as a seal to be able to use the choke easier........

#3 check and make sure the keyswitch and plate are grounded........
 

·
Banned
Joined
·
21,742 Posts
Ok so here is a pic.Are both these wires suppose to be grounded?
The double black wires get twisted together...

........The pushbutton and the keyswitch should be self grounding.if not ground the two to the engine case

I removed the key from my 2011 cag and just use the killswitch button on the handlebars only.......The red wire goes to the wire coming from the coil and the black grounds to the engine case with a terminal loop
 

·
Banned
Joined
·
24,145 Posts
Well, it was very dark. Is that a Pro Jet exhaust?? If it's a new engine everything is real tight so it may run alittle different than an old engine. On Walbro's on a Cag hp engine the back plate can shut to far and it cuts off the the flow to the engine and it stalls. Some I cut a small V in the bottom of the throttle plate on the shaft. Others I put a small thin piece of copper tube, or one barb off a brass barb fitting over the tip off the idle screw to hold the throttle arm open more for enough flow.
On the return line from the carb, I put a truck brake bleeding screw in the cap. With a gravity feed piston carb it's a tank vent, with a Walbro with its own fuel pump it becomes a tank return, now isn't that special,lol.
See my avatar bike photo.
 
1 - 20 of 82 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top