Pocketbike Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hey I bought a used X 15 pocket bike, it was pretty beat up so rather than junket I decided to fix it up 100%. The first thing I did was put a 125 ccmotor on. I swaped the motor out in one afternoon got it running, but I can't keep it running. I mean it runs, but I have the idol up higher than what it should be. Whenever I have it down it dies. Trying as hard as I can but I can't seem to get the air fuel and idle mixture's right. I had it to turns out it wouldn't run. so the way it is set up now is I have the air fuel screw all the way in and the clip is on the middle setting. It's a brand-new crate motor never started before. Any help with this would be great. When I had the air fuel mixture screw out two turns after you would accelerate and come down to normal speed to an idle the engine would die. I'm trying to keep it on the richer side than the leaner side but I noticed even with it running rich engine was getting warm warmer than usual
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Ok where do i buy one, what exactly am i looking for it had the same motor on it when i bought it with a stock carb n it ran good but when i swaped the motor i threw a new stock one on
 

·
Banned
Joined
·
24,145 Posts
Find a hobby shop and get a .3mm to 1mm guage drill set, there only good for alum & brass. That's .013" to .040" in small incraments. A 1/32" drill is hard to find and that is about .75mm.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Ok well i think i got it figured out but i have another q about the kickstand. Does the little washer on the stand go on the outside of the whole thing after u install or somewhere in the middle i put it back on after paint and its basically the same as its always been but even when i had the bike in whole it feels like it ready to fall over every time i park it.... or better yet any after market kickstand thats better?
 

·
Banned
Joined
·
24,145 Posts
The flat metal on the frame where it mounts bends and the bike gets lower and lower to the ground. Just a typical China bike,lol. You can put washers on the front side of the arm bolt to take some play out. Hardware store is a good place to get big washers.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
good info. Anyone ever try to put the x18 taillight on another model?
I have a tailight but its just a wire d bulb,, didnt know if it was possible or if a fairing swap is needed.....
 

·
Banned
Joined
·
24,145 Posts
Some bikes use the same tail light. The X7-X18 rear light has blinkers, running light and brake light. My rear bulb is a 5w/10w 12v. They are not road legal cause there not bright enough.
 

·
Banned
Joined
·
21,742 Posts
Some bikes use the same tail light. The X7-X18 rear light has blinkers, running light and brake light. My rear bulb is a 5w/10w 12v. They are not road legal cause there not bright enough.
Yep the cheapo chinese bulbs arent bright enough and the bulb sockets misshape easily..I had to retrofit my bikes with better lighting,,,,



This is what I do with the cheap chinese azz wiring for the lighting...............I rip it out and make my own..............

 

·
Registered
Joined
·
14 Posts
Discussion Starter · #10 ·
looks good man. I am going to take my bulb out today and try an led light.. or 2 cuz ther bright as ***ck. As for cam 2 u said about the jet.... correct me but its a carb ment for that bike... shouldnt need a bigger jet , plus it ran fine till i pulled the motor... new gaskets, no air leaks, i got it running.. but this is my concern. On some online stuff it says when tunning the carb with the bike running turn the air/fuel in and out till it rev high or its highest,,,, well the more u turn it in the higher it revs so idk what sense that makes,,, ive messed with it for bout 2 weeks and the only way it says running. is with the air fuel screw all the way in....rode it a bi saw that the accel was a bit sluggish so i moved my jet c clip. from. (i think i had it one ffrom the bottom ) to the middle..... rode it still a bit slugg.. so i might bump it up another one today and see what happens... im not a mech. but i can do sum stuff .. plulled the plug black if anything,.. im just not tryin to blow it up...
 

·
Banned
Joined
·
21,742 Posts
looks good man. I am going to take my bulb out today and try an led light.. or 2 cuz ther bright as ***ck. As for cam 2 u said about the jet.... correct me but its a carb ment for that bike... shouldnt need a bigger jet , plus it ran fine till i pulled the motor... new gaskets, no air leaks, i got it running.. but this is my concern. On some online stuff it says when tunning the carb with the bike running turn the air/fuel in and out till it rev high or its highest,,,, well the more u turn it in the higher it revs so idk what sense that makes,,, ive messed with it for bout 2 weeks and the only way it says running. is with the air fuel screw all the way in....rode it a bi saw that the accel was a bit sluggish so i moved my jet c clip. from. (i think i had it one ffrom the bottom ) to the middle..... rode it still a bit slugg.. so i might bump it up another one today and see what happens... im not a mech. but i can do sum stuff .. plulled the plug black if anything,.. im just not tryin to blow it up...
It doesnt matter if the carb is meant for the bike......The stock carb jetting is 38 pilot and 73 mainjet....

After I did a few simple mods like airbox removal,,muffler mod,NGK sparkplug and sparkwire mod I had to increase the mainjet to 75

Theres a bunch of things that could attribute to your problem....

an airleak........You stated you dont have an airleak but if the bike is still running with the a/f screw shut off then theres a serious airleak or your carb is madly underjetted in the pilot jet...........

carb float could be set incorrectly,,

valves need adjustment

You need a new sparkplug

Id remove the carb and make sure theres no crud in the floatbowl...ethanol coats everything then sluffs off causing quick carb problems

Make sure the tank is clean and clear and the fuel output is drilled to 1/4"

Replace the crappy weak anemic fuellines to 1/4",,the fuelfilter aswell

Drop the bowl and do the float restrictor tab removal mod

Make sure the float is set to 10 degree angle

Set the c-clip to the 2nd notch from the blunt end of the needle..Make sure the mainjet needle clip isnt missing aswell

Set the air/fuel to 2 full turns out,,,,

2nd notch and 2 turns out are the factory starting points on all chinese 4 stroke carbs.................Carbs are very easy and if you go to a Mikuni,,Keihin or sudco carb website you can get a relatively easy lesson on how a carb works,,what the jetting is for and what it does and how to totally adjust the carb to work correctly..Ive been cleaning carbs and tuning them since age 11.....
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #12 ·
great info. man im glad for the help cuz i am clueless on carbs, umm,, the bike is all stock but when you said air leak got me thinking.. cuz i did feel rpm s up and down when idle. So im currently pulling the carb,, looked pretty clean.. not to much crud around the gaskets,, ther both pretty much new... cleaned everything tighten back up... set the screw 2 turns out. New plug.,,,,,, i will post my findings
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #13 ·
started it up and fired right up runs good, thanks for the help. I think the thick rubbery gasket on the top half was not seated right. seems great now.. Its a new motor only ran about 2 tanks through it. Now that the carby is 2 turns out... i think the needle clip is on the middle setting.. think that is ok??... I know your posed to keep it rich during the break in. The only other problems with the bike is the exhaust pipe gets pretty hot... not red or anything but seems hotter than it should be idk,and i put on some guages,,, yes the crappy ones... and now i cant get my speedo to work......... again thanks for the help
 

·
Banned
Joined
·
21,742 Posts
Nice job getting it done.........The factory setting is two full turns out and it can be adjusted + or - 1 full turn to get the best takeoff and lower running temps..........
 

·
Banned
Joined
·
24,145 Posts
Might need to richen it up. Main or pilot jet or move the clip down on the main jet need in the carb piston.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #16 ·
yeah well i lost the one needle clip and broke the other one. I ordered a new one in the mean time.. any suggestions. thought i read you could use a washer or sumthing
 

·
Registered
Joined
·
4 Posts
Boys im new and I need your help. I cannot make my own forum yet so I will get to the point

I own an X7 Bullet from craiglist, it ran well up until my 3rd mile. The engine began to rev high like up to 12-15 mph on my speedometer without the bike even moving. When i attempted to accelerate, the engine just became louder and did not move an inch. I turned it off in fear of well getting blown to shreds. The other issue I am having is that something like an oil or dark substance is leaking from the engine or right above on to the carburetor and spark plug.

I hope I do not have to trash this thing because It is a gorgeous bike and I wanted one to learn about motorcycles.


If you can help, please, please help me out.
 

·
Banned
Joined
·
24,145 Posts
First off the bike is made in China. Sounds like your clutch pads are worn down to metal are close to it. That's probably why the engine is revving and your going nowhere. We are all in the same boat,Junk,lol.
Need to take the transmission off and you will see the clutch mounted to the flywheel. The're like little drum brakes shoes on a car. See photos.
The clutch has been modded.
 

Attachments

·
Registered
Joined
·
4 Posts
Really cool of you to post up and help me out


Do i have to take off the entire engine like you did? I can't believe the clutch pads would make this bike not move and rev high. i hate China haha.

is there a simple way to get this done? It was also leaking some sort of oil when it runs from the top of the engine.
 

·
Banned
Joined
·
24,145 Posts
You might have to take the right motor mount bolts out and loosen the left ones and pick it up on the right side take the reat of the trans bolts off and pull the trans, then you can get to the clutch. Take the 2 big bolts off.
 
1 - 20 of 20 Posts
Top