Pocketbike Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey everyone-

I just got into this in the last few days for something to do with my kids, and I'm having a helluva time getting them both riding...

This is the first bike I got-




I have no idea what it is. No markings or model or anything. It runs good except for a speed dependent vibration from somewhere. Straight gas means 4 stroke, and it's electric start. The bad: No lights or gauges work at all. Most of the wiring arrived with it in a wal-mart bag, and it was ALL ugly. I don't know what size it is, who made it, or where to get parts- BUT it runs, which isn't too bad for $130- right??

Continued next thread...
Any help appreciated- Thanks!
 

·
Banned
Joined
·
21,744 Posts
That is an X6........................Most likely a 70cc full auto 4 stroker................Looks to be in pretty good condition..........

Theres things you can do to spiff it up.............As far as other parts try sdscooters

Change the oil............Castrol 10w/40 4T 4 stroke motorcycle oil............Crankcase holds 3/4 of a full qt

Change the sparkplug..............CR7HSA....Plug gap is .030"

Upgrade the fuellines/fuel filter to 1/4"

Do the float restrictor tab removal mod

Do the head breather mod

Good luck with it............
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Plastics are pretty poor... I'd like replacements if I can find them, but what I really want is to get it working right. There is a vibration that increases/decreases with speed that is pretty bad, and none of the accessories or lights work. If anyone has parts, or a parts bike I'd love to hear from you.

And a wiring schematic would be friggin awesome!
 
1 - 3 of 3 Posts
Top