Pocketbike Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Man I hate these carbs! Well my neighbor has a Polini 911 and its fast as he'll, but lately as soon as you start it, it dies as soon as u give it gas. Choke isn't on, it's not bogging down, it just goes from idle to dieing, he has another carb for it, but it doesn't see, to work either. So basically yea, sometimes it runs and sometimes it doesn't, no idea so please help! Ill post a video on YouTube and send the link here as soon as I can, and btw it's running really rich. Thanks!
 

·
Banned
Joined
·
24,145 Posts
Sounds like your flooding the engine with gas and it dies cause there is not enough air fot it to burn the gas. Hows your float level is the float needle stopping the gas flow? What size main jet do you have?
 

·
Banned
Joined
·
24,145 Posts
I would pull the reeds, manifold and carb, check that the reeds are sealing and pull the float bowl and pull the 2 brass jets off, and make sure the bowl is clean.
 

·
Banned
Joined
·
21,742 Posts
I'm pretty sure it's a real Polini, freakin expensive, so it's all cleaned and it stiff does it, but when he tilts to the left, it runs right, but when he tilts the bike to the right, it does, weird man
Lean the float out a tad by dropping it 1/16" lower in the bowl.....If the bike runs like crap with a leaner float setting go larger on the mainjet................

If it still overflows disassemble the carb and take a Q-tip and clean out the needle seat really good and make sure the needle tip rubber isnt erroded or has foreign trash stuck to it............Good Luck
 

·
Banned
Joined
·
21,742 Posts
Still doesnt work we'll, and I'm not sure what u mean by dropping the bowl, and it says it takes 2 percent mix or somethin what's that?
How are you mixing the fuel...What ratio?

What grade fuel and oil are you using?

Hows your reeds sealing?

Have you checked for airleaks at the crankseals and carb mount?

Do you have a jetkit?

Have you done a compression test on the engine?

What sparkplug are you using and whats it gapped to?

Whats your squish setting?

Whats your current elevation and ambient temps?

Have you tried doing plug chops to see the tune.........?
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #14 ·
I mix gas 32:1

I use this Walmart oil stuff in a blue container in 8 oz

Reeds should be sealing fine

Ill look for leaks and all

Why would I need a jet kit if it all worked before ?

Compression is perfect

I use a champion spark plug and its gapped .30

I live in Las Vegas, mostly if u google it its called "anthem "
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top