Pocketbike Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Automotive tire Hood Motor vehicle Electrical wiring Automotive exhaust

Hey guys, bought a an Venom X15 90cc that was stored for a year. I tried starting it and it cranks, but won't start.
I cleaned the carb, changed the plug, changed oil, drained the gas. If I put starter fluid in the carb it starts then dies. Fuel flowing from the tank, not sure if it's making it to the carb. The unusual thing is that it has two fuel filters, I've never seen that on other bikes. Does anyone have any idea if this is the root problem?

Pictures shows my Repsol bike with 2 fuel filters and another bike with one.
Wheel Tire Vehicle Automotive tire Automotive lighting
Automotive tire Hood Motor vehicle Electrical wiring Automotive exhaust
Motorcycle Automotive lighting Automotive tire Motor vehicle Automotive design
 

Attachments

· Administrator
Joined
·
3,827 Posts
Take the fuel line off and check and make sure fuel drains out of the fuel line once you have fuel getting to the carburetor if you still have it starting where it'll run briefly off of starting fluid and then die then probably replacing the carburetor is in order.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hey thanks for responding. So the fuel drains from the tank. What I'm not sure of is if its flowing into the carburetor. I don't see it going into the fuel filter once I connect the hose. I removed one of the filters because it didn't make sense to have two. Not sure why this was done.
 

· Registered
What's your poison? Mine is 40:1
Joined
·
1,728 Posts
Someone overly cautious. Definitely a fuel delivery problem. Do like Kitty said and if it's still not working, I would probably try and start it a few more times on spray to see if the carburetor starts sucking in fuel. I personally would try to clean it but the carburetors are cheap these days.
 
1 - 4 of 4 Posts
Top