Pocketbike Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
ok so i just got an x18 107cc, plug was loose blew out took threads i tried heli coil repair then spark plug broke in head, well i bought a 110cc complete head installed it and when i got it started it started to pop and backfire and if i let it idle it stalls also i saw smoke from the head area what the heck did i do wrong
 

·
NO GOOD DEED GOES UNPUNIS
Joined
·
1,278 Posts
I would suspect its not timed properly or the valves are not adjusted correctly are you sure those are correct
 

·
Ninja Racer
Joined
·
2,767 Posts
im guessing, the valves as was said, possible proper torque on the head bolts (10ftlbs)
or a missing or damaged gasket or washer
to set the timing you gotta have the T on the flywheel match up with the notch in the head and cam gear
 

·
Registered
Joined
·
355 Posts
Yup, my vote too for incorrect cam timing...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Since we agree it's timing how do I get to the flywheel I can't get the cover off I took off the surrounding 8mm bolts but cover still feels like it is being held on somewhere
 

·
NO GOOD DEED GOES UNPUNIS
Joined
·
1,278 Posts
There is a bolt on the other side of the motor if I am remembering it correctly I don't remember which one but try to loosen up one at a time until it tells like its giving more but there is def a bolt on the other side of the motor that goes through to hold it
 

·
Ninja Racer
Joined
·
2,767 Posts
there are 3 bolts
turn the flywheel counterclockwise till the T
the cam gear cover comes off by the bolt opposite it
 
1 - 7 of 7 Posts
Top