Pocketbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have two Razor mx350 dirt bikes. Both ran fine up until recently. They both had new batteries that were only a couple months old. All of a sudden they stopped charging. I thought the batteries had crapped out, so I replaced them. I also replaced all the electrical on one and the charger port on the other. Both worked great until I charged them and the batteries died again. This has to be a charger problem right? I tested them with a multimeter and it shows 28.2v. Any ideas.
 

·
Registered
Joined
·
376 Posts
Sounds like it, if it were me I would take a couple regular 12 volt Chargers and charge each battery individually, get them up to the full charge and test out the dirt bikes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I tried that when I removed them to change batteries. They show 12+ volts on a load tester, but as soon as I put the load on them they go down to dead on the meter. I actually threw out all my chargers and bought new ones. Daughter took bike for a 3 mile ride today. Plugged it in and it's not charging. I will pull batteries tomorrow and see if they're dead now.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well the new chargers I got were no good to me. They actually have power all the way to the charger port wires, but apparently won't go through the controller to the batteries. Not sure why. I tried them on a couple of 24v scooters and the same thing happened. I ended up trying my neighbors charger and it works on everything. I'm guessing it was a bad charger.
 

·
Registered
Joined
·
376 Posts
Sounds like it, too bad you went through all those chargers. I have had quite a few bad ones as well. I keep the good ones after I sell bikes and give a new charger with them. Glad its working.
 
1 - 6 of 6 Posts
Top