Pocketbike Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
My x18 was working perfectly until 1 day i started it up and it turned on and shut off, i though maybe just the engine was cold but it wouldn't start up again. So i looked up on the internet and came up with this i checked and switched the ngk spark plug changed the oil / drained the old oil made sure fuel was getting to the carb running perfect opened the screw on the bottom of the carb checked the cdi plugged in , when i press the starter it sounds as if it would start normally but doesn't turn over no mater how long i do it for, ( dont do it to long don't want to screw up the starter , also i read i should try and kick it ,so i do and its still not starting up and the spark plug hole has great compression PLEASE SOMEONE HELP ME!
 

·
Banned
Joined
·
21,744 Posts
Take a digital multimeter and test your stator and do a continuity test on the keyswitch.......

If those checks out look for loose wires on the coil,,CDI and harness plug going into the stator plus make sure the grounds are good...............
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
cam am i aloud to use 4t 10w40 fully synthetic oil on the bike? and everything checks out fine the plugs lines wires i went up my block and rolled sown kicked it into second it started and when i stopped rolling it shut off and its not staying on and other than that it wont start up at all
 

·
Registered
Joined
·
355 Posts
Need more specific details. Check the simple things first. Are you getting power and lights when you turn on the key ? pull the plug and see if you have spark ? Is the plug wet with gas ? Check the main electrical fuse in the frame ?

Remember you need fuel, spark, and compression and your engine should at least try to start..... if your engine does nothing your missing one of the three...

One last comment just because you opened the carb bowl screw and verified fuel coming out, this doesn't mean that fuel is being drawn up through the main jet into the carb venturi. A very commone problem is dirt/Ethanol debris spooge and water clogging the main jet.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
ok so been riding my amazing bike for about a month or 2 and got a few maintenance questions and 1 problem,

1. can i start to put premium fuel in the bike

2. what kind of oil should i use i was told synthetic but was coming to you first.

3. my bike was working and running like a champ hitting 55 and when i put more oil in i feel like some of my power went away not much but i forgot to drain the old oil. FML lol

so now with the problem, i started my bike 1 day it went on and shut off so i though ok the engine is cold but then it wouldnt start up again , so i took all the plastics off and did this,

1. checked the spark plug , didnt look to bad but cleaned it off put it back in and nothing so i went to the store and bought a new 1 anyway,

2. checked the compression of the bike i put my finger over the sparkplug hole and have amazing compression .

3 took gas line off and made sure gas was flowing yes all good.

4 checked air filter perfectly clean

5. checked fuse put a new 1 in all good

6. checked wires everything is connected.

7. tried kicking the bike nothing also electric start nothing, the bike sounds like it wants to start but its just not firing up

so the last thing i tried was i went to the top of a block rolled with the bike popped it into 2nd and it went on but when i held in clutch it shut off or if the bike stopped rolling it shut off so it only went on for a second

man im really bummed this is happening i love my bike and just want it to run please tell me you can help!

will give money if you fix my problem via paypal!
 

·
Registered
Joined
·
355 Posts
ok so been riding my amazing bike for about a month or 2 and got a few maintenance questions and 1 problem,

1. can i start to put premium fuel in the bike

2. what kind of oil should i use i was told synthetic but was coming to you first.

3. my bike was working and running like a champ hitting 55 and when i put more oil in i feel like some of my power went away not much but i forgot to drain the old oil. FML lol

so now with the problem, i started my bike 1 day it went on and shut off so i though ok the engine is cold but then it wouldnt start up again , so i took all the plastics off and did this,

1. checked the spark plug , didnt look to bad but cleaned it off put it back in and nothing so i went to the store and bought a new 1 anyway,

2. checked the compression of the bike i put my finger over the sparkplug hole and have amazing compression .

3 took gas line off and made sure gas was flowing yes all good.

4 checked air filter perfectly clean

5. checked fuse put a new 1 in all good

6. checked wires everything is connected.

7. tried kicking the bike nothing also electric start nothing, the bike sounds like it wants to start but its just not firing up

so the last thing i tried was i went to the top of a block rolled with the bike popped it into 2nd and it went on but when i held in clutch it shut off or if the bike stopped rolling it shut off so it only went on for a second

man im really bummed this is happening i love my bike and just want it to run please tell me you can help!

will give money if you fix my problem via paypal!
None of us want your money. We are glad to try and help, even more glad when we help u FIX the problem. You still have not answered our question : do you have spark ? Pull the plug, insert the plug into the wire and lay the plug on the cyl and kick the engine over with the key on you should hear a snap, and see the spark at the plug tip. It helps to do this test in the dark.

second when you say " took gas line off and made sure gas was flowing yes all good."

read my reply again : "just because you opened the carb bowl screw and verified fuel coming out, this doesn't mean that fuel is being drawn up through the main jet into the carb venturi. A very commone problem is dirt/Ethanol debris spooge and water clogging the main jet. " A quick test to tell if you have a plugged carb is to spray starting fluid into the carb venturi, and kick the engine over if the engine starts and dies after a few seconds, you now have found the problem you have a clogged carb
 

·
Registered
Joined
·
38 Posts
A quick test to tell if you have a plugged carb is to spray starting fluid into the carb venturi, and kick the engine over if the engine starts and dies after a few seconds, you now have found the problem you have a clogged carb
If the bike has a clogged carb, will it start and have rough idle, or will it not start at all?

OP, sorry to threadjack, but I'm having similar problems. Bought all new stator, CDI, spark plug and ignition coil and the thing just wont turn on.
 

·
Registered
Joined
·
8 Posts
X2 pocket bike only go 15 mph help!!!

I have a X2 pocket bike and its very slow it go 15 mph and when going top speed the engine sound like its pulling hard can you tell me what's wrong
 

·
Registered
Joined
·
27 Posts
My x18 just started this. I fired it up the other day. It ran for 2 seconds, shut down on it's own, and it will not start with the stater nor kick start. I don't even have 5 miles on the bike. I haven't had time to delve into finding the problem. My guess is that it's electrical but with these bikes, weho knows. seems to be a common problem.
 

·
Registered
Joined
·
27 Posts
Forgive my lack of correct spelling..lol. I'm trying to feed my son and type too. My 18 will not start with the starter nor the kick starter.
 

·
Ninja Racer
Joined
·
2,767 Posts
its almost always the carb
other parts can die but its usually gas related
ex: slag in the fuel tank-lines-carb
ranger if you just hopped on and rode then this is what can happen, course they dont tell you all this when they sell you the bike
always use 93, its a half a gallon tank! splurge
 

·
Registered
Joined
·
355 Posts
My x18 just started this. I fired it up the other day. It ran for 2 seconds, shut down on it's own, and it will not start with the stater nor kick start. I don't even have 5 miles on the bike. I haven't had time to delve into finding the problem. My guess is that it's electrical but with these bikes, weho knows. seems to be a common problem.
The new E10 fuel leaves behind a fungus when the fuel evaporates or sits in the system for extended periods of time. The E10 fungus most likely has your carb inlet needle and seat stuck shut. Common issue.
 
1 - 12 of 12 Posts
Top