Pocketbike Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
I have an x7 and gas leaks out of exhaust where it mounts. Its not the carb cause i recently just bought a new one. Every time i try to jump it with my dad truck, even more gas comes out of the engine but it still doesnt fire cause the motor is maybe flooded. Can you guys pleaseee help??
 

·
Banned
Joined
·
21,742 Posts
Gas will still leak out the motor from the exhaust unless i take the gas lines off. Do u think i need piston rings??
No I think the pumper needle in the carb is stuck open or the needle tip could be erroded off and as another possibility the pumper diaphragm is super warped and pushing the needle open.....

 

·
The 2-Cycle DocToR
Joined
·
222 Posts
Could be the diaphragm in the carb is stuck too. Take the carb off and unscrew the bottom four screws, remove the bulb and gasket, the diaphragm is underneath the gasket. Pull it out and lightly blow on it to Clean the gunk out.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #10 ·
I found out that it wasnt the carb so i took the motor apart by just taking the cylinder off. I noticed that the cylinder had some type of a build up on top of the piston but the rings are still good. The piston has burn spots like its been turned partially brownish, black color. Soo my father think it may be the gasket around the cylinder that needs replacing, what do you guys think?
 

·
Banned
Joined
·
24,145 Posts
Go to Honda or Yamaha and get a tube of yamabond or honda bond in a tube. Scrape and clean the cases and cyld where they meet. Put the cyld back on at TDC and the cyld off the cases, spread a thin layer of bond on the cases it's rubbery and dries very fast. Quickly drop the cylinder down on the yamabond, do not push on it, put the 4 bolts in till the just touch the cyld flanges, let it sit all night and torque the cyld down. It will raise your compression. You could port the cyld while its off. Raise the exhaust port and lower the intake port, in a V shape to the upper middle or lower middle on the intake. CAM2 has all kinds of pictures and text telling how to do it.
 

·
Banned
Joined
·
24,145 Posts
Try turning the high speed screw out 1/4 of a turn at a time, and see if that makes it run better.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top